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Team Manager for Swimming provides coaches and administrators with easy-to-
use software designed to greatly simplify the administration and performance 
tracking for teams at all levels of competition.

The key to effective use of Team Manager is to be organised and consistent in 
how you use and maintain the database.

● Keep the information in it current

● Back it up after every update

● Have a logical folder structure for where the database, the backups, swim 
meet entries and all other related artefacts reside.

Experiment
Create a test copy of your master database and try different things. Change 
dates, create reports, use Team Manager to help determine your annual award 
winners, find out how you can use time standards, maintain your club records. If 
you break the test copy of your master, don't worry. Delete it and start again.
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● Create, maintain, view and print member personal details and attendance lists

● Easily select swimmers for entry into Swim Meets

● Import results from Swim Meets

● Track “Best Times” by swimmer, stroke, gender or age

● Maintain club records and Qualifying Times

● Create a multitude of customised performance and attendance reports

● Track swimmer progress over time – with graphs

● Automatically pick the best freestyle and medley relay teams

● and much, much more.....

Team Manager makes running a team simple
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An Introduction to Team Manager

The first thing to do is build your Team Manager database. Follow these simple steps.

● File → Open/New; name the database something meaningful. eg: BendigoHawksSC

● Complete the Team/Swimmer Defaults

– Default Team Registration – AUST

– Default Team Type - AGE

– Default Country - AUS

– Default LSC - VIC

– Default State - VIC

● Set the Meet Age-Up Date - Meet Start Date

● Set the System Age-Up Date - Always Age-Up To Today

Tip: Go to Set-up → Preferences → System Preferences at any time to alter the Meet Age-Up Date 
or the System Age-Up Date. Altering these values may change the age of some or all of your 
swimmers. For example, it can be way to build a report that will forecast what a relay team might 
look like at a future Meet.

Building a database
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First, add your Club to the Teams list

● Teams → Add

● Add the Club Team Code. Refer to the list of Club names on the Resources page of 
the SV website to get the accurate Team Code for your club. It is very important that 
this be accurate.

● Add your Club Name

● Add any other information about your club

Next, add your swimmer's names

● Athletes → Add

● Add as much information about the swimmer as you wish too.

● Mandatory fields are: Last Name, First Name, Date Of Birth, Gender, Team Code

● Press the Build Id button to build the swimmer's Registration Id

Tip: The first time a swimmer's results are loaded into the database his Athlete record, with only the 
mandatory information, will be automatically created.

Adding Swimmers
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An Introduction to Team Manager

● Entering a meet is easy and eliminates the tedious data entry that is normally 
necessary.

● Team Manager will list all eligible swimmers and the events they qualify for.

● Simply click on the events to be participated in by each swimmer. It's easy, fast and 
accurate!

● Team Manager can then export these meet entries for the meet host.

● Team Manager will select the best relay teams based on the best times of each 
swimmer.

● For Medley relays, the best times of each swimmer for each stroke is considered, to 
build the fastest team overall.

● For the Host Club, receiving a Team Manager Entry File from a competing Club is a 
godsend. Literally dozens of swimmers can be entered into dozens of events in a 
matter of seconds – with complete accuracy.

● Help the Host Club and send all your entries via a Team Manager Entry file.

Entering Meets
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● Download the TM Event file  from SV or the Host club's website. This file contains all 
of the events for the Meet. It'll be called something like this when it is downloaded:- 

– Meet Events-2015 Central Victoria Swimming Championships-01Mar2015-001.zip

● Import the TM Event file into your Team Manager database

– File → Import → Meet Events

● Get a list of all the events in the Meet

– Meets (click the Meet you wish to enter)→ Entries → Entry by Event

Build the Individual Entries for a Meet
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● For each event you will see only the swimmers who are eligible to enter that event 
based on the entry conditions of the event. Select your Club from the “Swim for 
Team” drop-down list

● For the first event click the “Entrd” check-box for each swimmer who wishes to swim 
that event. Their PB will be displayed and automatically used for entry. You can 
override the PB by entering a time in the “Custom” field. Work your way through each 
event in the same manner.

Build the Individual Entries for a Meet
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● Click the “Relays Only” menu item. Just the relay events will be shown.

● All the eligible swimmers for the first relay event will be listed

● Click New Relay → Find Best Relay. Team Manager will automatically pick the fastest 
relay team, in the standard order (2nd fastest,4th fastest,3rd fastest,1st fastest) and calculate 
the entry time.

● If you wish to enter a “B” team simply click New Relay → Find Best Relay again. 
Repeat the process for a “C” team and so on.

● Alternatively, you can build relay teams based on your own club's criteria. Click New 
Relay and the click the Entrd check-box for each swimmer you wish to enter. Click 
the Calculate Custom button to calculate the entry time.

● Work your way through each relay event in the same manner.

Build the Relay Entries for a Meet
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Tip: If you click on the “Best Time” heading the eligible swimmers will be sorted from fastest to 
slowest for the stroke selected in the “Best” drop-down list.

Build the Relay Entries for a Meet
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Once you have finished selecting the individual entries and relay entries you are ready to 
create the TM Entry file. This is the file you will send to the Host club.

● Go to the “Home” screen

● Click File → Export → Meet Entries

● Choose the Meet you wish to create a TM Entry file for from the Meet drop-down list

● Choose the folder on your computer you want the TM Entry file to be placed in.

● Click the “Export Relays” check-box.

● Click OK. A dialog box will open confirming that a TM Entry file has been created in 
the place you specified. The file will be called something like “BHA-Entries001.ZIP”.

● This is the file you will send to the Host club.

Tip: You can go through the whole Meet entry process from beginning to end as many times as you 
like for a given Meet. Each iteration is cumulative. That is, selections already made will be 
remembered, any new ones will be added, any de-selections will be removed and any changes will 
be changed. 

Create the TM Entries file
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After a Swim Meet has completed you will need to get the results into your database so 
you have a record of each swimmer's efforts. Any PB's set will be automatically updated.

Once a Meet has received SV Approval the results will be published on the SV website. 
Results are published in PDF, Team Manager and Meet Manager format. Go to the SV 
website or the Host club website and download the Team Manager results file for the 
Meet. Place the file in a logical place in your folder structure.

● File → Import → Meet Results. When downloaded the file will be called something 
like “Meet_Results-Echuca_Swimming_Club_Annual_Spring_Carnival-21Sep2014-001”

● Select the Meet Results file

● A dialog box will open. For Import Criteria click the check-box for:-

– Overlay duplicate results – this will allow you to import the results many times

– Add New Teams/Athletes – this will add new athletes to your database

● Enter your Team Code in the One Team field and press OK

Your database will be updated with the full results from the Meet in a matter of seconds.

Tip: Backup your database straight away.

Getting results into your database
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Backup is simple. From the Home screen...

● File → Backup. A dialog box will open asking where you want to store the backup.

● Select the Backup drive and the Backup Directory (Folder) and press OK. The 
backup file will be created in that place and called something like:-

– SwTM5BkupBendigoHawksSC-01.zip

Restore is a littler more involved. From the Home screen...

● File → Restore. A dialog box will open asking which backup file you wish to restore.

● Select the file. In this case SwTM5BkupBendigoHawksSC-01.zip.

● Another dialog box will open asking how and where you want to restore the backup

Backup / Restore your database
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● You can 1) restore straight over your open database, 2) restore to the same folder but 
with a different name or 3) restore to a different folder with a different name. Option 3) 
is the safest. Never let go of what you've got, until you've got a hold of something 
else!

Tip: Backup your database after every session. With a good, regular backup safely tucked away you 
can work in Team Manager without the fear of losing all your hard work and data history.

Backup / Restore your database
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An Introduction to Team Manager
Reports

Customising Age Groups– Set-up → Preferences → Report Custom Age Groups

You can easily customise the Age Groups that are used in reports to suit the particular 
needs of your Club.
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Individual Results Report - Athletes → Select a swimmer → Results

This report will show all sorts of useful information about the performances a given 
swimmer in your Club.

Reports
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Individual Results Report - Athletes → Select a swimmer → Results

● The screen shows the PB's for that swimmer over every stroke , distance and course.

● Every result in the database can be displayed by un-checking the Fastest check-box. 
The results of that action can be further refined by filtering on Time standard, Course, 
Meet, Stroke, Distance, Since date.

● For example, you can easily zero in on the swimmer's 200m LC Backstroke results 
since the start of the season or perhaps the swimmer's 100m times for all strokes at 
given Meet.

● The resultant report will detail stroke, distance, time, meet date, meet name, event #, 
placing and much more.

● It can be easily printed using the Print menu item.

Tip: Clicking on one of the results will show the Splits for that swim.

Reports



  

An Introduction to Team Manager
Reports

Top Times Report – Reports → Performance Reports → Top Times

A very useful report for determining the fastest swimmers in your Club

The filters set on this screen will create this report.........
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Reports

Top Times Report – Reports → Performance Reports → Top Times

For this report I chose to set a filter which displayed the flag CLC if the swimmer's time is 
a Country Long Course qualifying time.
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Reports

Attendance Report – Reports → Meet Reports → Number of Meets Attended /  Splashes

A good report for quickly determining how many Meets a swimmer has attended and how 
many events he has competed in.
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● Build your initial Records database entries using Records → Add/Edit Records

Records
It's easy to maintain and update Club Records with Team Manager. Records can be 
quickly updated with the press of a button.



  

An Introduction to Team Manager
Records

Tip: If you do not check the Update Records check-box a Record Update report will be produced but 
the records will not be updated.

Any time you like you can update the Club Records.

● Reports → Performance Reports → Record Match



  

An Introduction to Team Manager
Records

Here's a sample Record Match report
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Time Standards (aka Qualifying Times)

It can be very handy to set-up a number of different Qualifying Times in your Team 
Manager database. For example, Country Long Course, State Age, Open Short Course, 
District Championships etc. When producing certain reports you can easily see which QTs 
a swimmer has and which he still has to attain.

● Standards → Add/Edit Standards
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Time Standards (aka Qualifying Times)

When producing certain reports you can easily see which QTs a swimmer has and which 
he still has to attain.

● Athletes → Results → Standard (CLC) → Show Standards will produce this report which 
shows which events the swimmer has a Country Long Course QT for.
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Adding results manually

If you can't get your hands on the electronic results for a Meet you can add those results 
to your Team Manager database manually. The process is a bit complex but it doesn't 
happen very often.

● Add the Meet to the database – Meets → Add
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Adding results manually

● Add the Entry Events and Result Events required - Events → Entry Events → Add
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Adding results manually

● Add the Results - Results → Results by Event

● Check that the results have been added - Athletes → Results
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An Introduction to Team Manager

Help – Help → Contents

● Team Manager has a very good built-in Help feature

Reference

There is also a very good User Guide the can be downloaded from the ActiveHy-Tek 
website - http://www.hy-tekltd.com/downloads.html 

http://www.hy-tekltd.com/downloads.html
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